Chevy Colorado & GMC Canyon banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello everyone, hoping for a little help with my truck. 2009 Canyon. Went to start yesterday morning and I heard a clicking noise as I turned the key. The gauges started vibrating for a second before dying. Then the check engine and passlock lights came on. ABS traction fault came up on the odometer screen. Then there was a weird click underneath the hood (in the box? beside the oil plug, guessing the starter and/or alternator is in there). The clock reset to 12:00 also. Truck won't start. I've let it sit for a while, tried again with the exact same results. Same with today.

I tried to give it a jump but that didn't work. Any clue what this could be? Battery is an original so I plan to to replace it if I can get it started to drive to AAP.

Any help is much appreciated!
 

·
Registered
Joined
·
4,254 Posts
:welcome to C'Fans.

If you are jumping from another vehicle, let that vehicle run for 15 minutes or more before trying to start your truck. Also try removing one of the battery cables and attaching the jumper cable to it.
 

·
Registered
Joined
·
395 Posts
Totally sounds like your battery, but clean all your connections. Sometimes they look clean from the outside, but may be corroded inside. Probably need a new battery since its original from 2009. That's long for a battery!
Get a ride from someone and pick up a new one.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Update: positive connector broke in half when it was removed. It wasn't super corroded but very weak and pliable. Battery is out and I'm heading to the store tomorrow morning.

Thanks for the help!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top