Chevy Colorado & GMC Canyon banner

1 - 20 of 28 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
I took my truck in to get this TSB done and while I hate being suspicious of something. Is there a way to tell if they applied the flash besides just the feeling of the shift changes? Like being able to take it to another credible mechanic who can check the firmware version?
 

·
Registered
Joined
·
1,631 Posts
Did you get any change in performance?
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
So my reasoning for this question is that there is an initial change in performance. However, i'm noticing with it starting to warm up outside to the low 90s that when the truck starts to warm up there seems to be that hesitation again when cruising.
 

·
Registered
Joined
·
54 Posts
I took my truck in to get this TSB done and while I hate being suspicious of something. Is there a way to tell if they applied the flash besides just the feeling of the shift changes? Like being able to take it to another credible mechanic who can check the firmware version?
This is the biggest reason that I haven't requested it yet. My luck they wont even do it. I thought I may tell them I will go for the extended bumper to bumper thing they've been trying to sell me if they can make it behave as it should.
I hate to be suspicious too but I've had some bad experiences ....as have most of us.
 

·
Registered
Joined
·
765 Posts
All I know is there was a noticeable change in acceleration at any speed, my Canyon drove totally different, I think you would notice.
I don't know why a dealer would "Fake" doing it and list it on your invoice whether they charged you or not.
My dealer did it for free, but it was still on the printout.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #8
but it being on the print out of their service invoice doesn't mean they completed it right? i did get charged for because i was requesting it to be done without them troubleshooting my issue.
 

·
Registered
Joined
·
4,713 Posts
I cant say I noticed any difference when mine was done but, I didnt have any issues when I brought it in. I only took mine in as the 3 year warranty was ending and they did it no-charge. I did in fact confirm when I went back to work that they flashed the 2 modules.
 

·
Registered
Joined
·
4,713 Posts
There would be no reason for them to lie that they did it for 2 reasons.
1st, its easily traceable if they did or didn't do it.

And 2nd.....while they charge an hour or so for the procedure, it literally takes 5 minutes to do. Plug in the laptop, talk to the modules, click the proper trans module to flash and walk away to get a cup of coffee.

Come back 10 minutes later, now select the proper BCM module to flash, go to the mens room to get rid of the previous cup of coffee and poof, its done.

(and yes, 2 modules need to be flashed for this TSB)
 

·
Registered
Joined
·
1,631 Posts
I never had a ECM flash, just wifi updates. I get occasional hesitation
but not bad enough to take in.
 

·
Registered
Joined
·
4,980 Posts
I never had a ECM flash, just wifi updates. I get occasional hesitation
but not bad enough to take in.
The above TSB pertains to the 15 & 16 LFX V6's with 6L50's. When I got my 15, the programming was such a departure from my previous Camaro with the same motor and trans feel, I put a tune on it at 1500 miles.
 

·
Registered
Joined
·
4,488 Posts
This is the biggest reason that I haven't requested it yet. My luck they wont even do it. I thought I may tell them I will go for the extended bumper to bumper thing they've been trying to sell me if they can make it behave as it should.
I hate to be suspicious too but I've had some bad experiences ....as have most of us.


Just have them give you a printout
 

·
Registered
Joined
·
54 Posts
This is the biggest reason that I haven't requested it yet. My luck they wont even do it. I thought I may tell them I will go for the extended bumper to bumper thing they've been trying to sell me if they can make it behave as it should.
I hate to be suspicious too but I've had some bad experiences ....as have most of us.


Just have them give you a printout
Good deal. That is what I will do.
There was a guy in a different thread said the TSB put his 0-60 time into the 6s. That is appealing. I like to smoke Tacomas.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #17
There would be no reason for them to lie that they did it for 2 reasons.
1st, its easily traceable if they did or didn't do it.

And 2nd.....while they charge an hour or so for the procedure, it literally takes 5 minutes to do. Plug in the laptop, talk to the modules, click the proper trans module to flash and walk away to get a cup of coffee.

Come back 10 minutes later, now select the proper BCM module to flash, go to the mens room to get rid of the previous cup of coffee and poof, its done.

(and yes, 2 modules need to be flashed for this TSB)
Well, it did take them half a day to complete this 10 minute task and the service advisor had given me an update stating that they were having trouble with the update. Something about it not syncing and/or the update was failing so they kept trying.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #18
Also, I think I just figured out why I’m asking this. On my way home today after the truck warmed up and it being a hot day as I came to a stoplight and turned right it completely lost power. I finished the right hand turn and it was like it died, it wasn’t accelerating until I pressed the gas pedal almost all the way down. It did it again when I was cruising along and turning.
It doesn’t accelerate and hesitates. This happens after it warms up.
 

·
Registered
Joined
·
4,488 Posts
Also, I think I just figured out why I’m asking this. On my way home today after the truck warmed up and it being a hot day as I came to a stoplight and turned right it completely lost power. I finished the right hand turn and it was like it died, it wasn’t accelerating until I pressed the gas pedal almost all the way down. It did it again when I was cruising along and turning.
It doesn’t accelerate and hesitates. This happens after it warms up.
I don't know whats up with it. After I had mine updated it drives like a dream. And it wasn't all that bad before.
 

·
Registered
Joined
·
350 Posts
I cant say I noticed any difference when mine was done but, I didnt have any issues when I brought it in. I only took mine in as the 3 year warranty was ending and they did it no-charge. I did in fact confirm when I went back to work that they flashed the 2 modules.
Since you have the latest transmission update, could you do me a favor and go to the link below and post your calibration history for the transmission? My truck is having all kinds of issues with drivability at low RPM and it is getting very annoying. When I took mine to the dealership right before my 3 year warranty was up they told me there wasn't any issues and I had the latest software updates.

Enter VIN ID and select Get Cal ID
Select "K71 Transmission Control Module" then NEXT
Select "Programming" then NEXT
Select "Normal" then NEXT
Select "Complete History"

377923


377926
 
1 - 20 of 28 Posts
About this Discussion
27 Replies
14 Participants
theredmeadow
Chevy Colorado & GMC Canyon
ColoradoFans.com is the best forum for the Chevy Colorado community to discuss the truck’s reliability, diesel or transmissions problems and more.
Full Forum Listing
Top