Chevy Colorado & GMC Canyon banner

1 - 8 of 8 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Background info:
Truck does NOT sit outside, it is parked in the garage during the night. Live in Western Washington so the temperature is rarely freezing. My Colorado has 31,000 miles on it and is virtuall stock, only engine mod is a K&N airfilter and flowmaster 50 delta flow exhaust system....

Problem:
After driving, whether its five minutes or an hour, ill let it sit for about ten to fifteen minutes while, for example, I go into work and get my upcoming weeks schedule. I'll come back out, put the key in, and attempt to start it. The starter turns over just like it normally would when you start your truck. But then it doesn't start....it just continually turns over until you let go of the key. I try again every 30 to 45 seconds for a few minutes. If it doesn't fire, I try what the manual says...Hold pedal to the floor while turning over...that has yet to work for me.. After attempting that, I just let it sit for like five minutes, try to start it normally, and it usually fires up.. Overal process takes 15 to 20 minutes. Any ideas as to why this happens?? Anyone else have this problem??? Like I said, it has only happend two or three times over the last four months. Still is odd to me for being such a new truck..

2004 Chevy Colorado LS I5-3.5L
 

·
Registered
Joined
·
591 Posts
When truck cranks, but will not fire; check if Passlock icon is flashing on dash display. If it is, injection is locked out for 10 minutes. Possibly a bad ignition switch.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
I've never seen anything flashing on the dash when this has happened, but if it happens again i'll look for that. Thanks.
 

·
Registered
Joined
·
550 Posts
Hey bud, this happned to my new 07 a whole bunch of times, run into store, come back out and try to start it and nothing for about 10-15 mins. Only thing you can do is sit and wait, but keep the key in the on position and you should see a red PASSLOCK light flashing slowly down by the speedo. About ten mins later shut off key then try again, light should be SOLID which is a big ten-four ;) As for what is causing this problem I have no idea, maybe the igniton switch like some guys said, i have no idea. I never got it checked out since it hasn't happened in a Long time so I figured it went away. Best of luck.
 

·
Registered
Joined
·
2,966 Posts
This has happened about 20 times to me over the past year or so. PIsses me off, but I haven't had time to get it looked at and I'm trading her in this week so dont care. I have tried everything to remedy it, but only time fixes it. I have tried dis-connecting the battery, taking out the ignition fuses, locking and un-locking, setting off the alarm then disarming it...nothing works. Just have to wait and try again until the Passlock icon stays solid, or take it to the dealer!
 
1 - 8 of 8 Posts
Top