Chevy Colorado & GMC Canyon banner

1 - 20 of 21 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I bought my 2015 Colorado Z71 in January. Almost a week after I bought it the serve theft deterrent system light starting randomly coming on when I started the truck. Sometimes the truck will stay started but other times it just kills the engine. I have to remove the key and open the door to get it to start. Dealership has tried 3 times and it's still acting up. Anybody else having these issues. The first 2 times there were no known issues so they would work with the Colorado plant and after the 3rd time it was "under investigation". Just waiting for possibly a recall. We'll see. It's pretty irritating
 

·
Registered
Joined
·
2,398 Posts
Don't think it will be a recall if there is 1 or 2 trucks with the problem. Go to a different dealer if those guys can't find it. Nothing new in the theft deterrent sys that GM is using in the twins. Steps I would take are read codes, relearn the key transponders, reprogram the BCM. If there are no codes, at least it acts up frequently enough to troubleshoot. Not an issue for a good tech to find.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
And when the light comes on it doesn't store the code. One time I was able to get it to the dealership with the light still on and it came back with something with the antenna. Replaced and still doing it. I'm about to just say to **** with it and go get a different truck.
 

·
Registered
Joined
·
2,398 Posts
Lemon Law if it applies in your state. After a reasonable amount of time (say 60 days) and 3 attempts, I would hope that most states have some sort of consumer protection that would force the dealer to buy it back.
I think security codes and airbag codes are live only, and don't have history recorded.
 

·
Premium Member
Joined
·
811 Posts
I bought my 2015 Colorado Z71 in January. Almost a week after I bought it the serve theft deterrent system light starting randomly coming on when I started the truck. Sometimes the truck will stay started but other times it just kills the engine. I have to remove the key and open the door to get it to start. Dealership has tried 3 times and it's still acting up. Anybody else having these issues. The first 2 times there were no known issues so they would work with the Colorado plant and after the 3rd time it was "under investigation". Just waiting for possibly a recall. We'll see. It's pretty irritating
Hi txdolo,

We see you're having issues with the theft deterrent system in your new Colorado and understand how frustrating this has been for you. Please know we want you to have a pleasing ownership experience with your truck. We'd like the opportunity to follow up with your dealership and research this further with our internal resources. Could you please send us a PM with your contact info, VIN, current mileage and the involved dealer? Once we receive your message we'll follow up with you there. Hope to hear from you.

Sincerely,

Eddie A.
GM Customer Care
 

·
Registered
Joined
·
61 Posts
I just got this light this morning when I remote started.... Except I'm still driving with it on...

One: I don't like how this is malfunctioning and don't trust it now.

Two: if it turns on and detects it, why is it letting me drive still?!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15 Posts
I got the "Service Theft Deterrent System" message this morning on my 2015 but I was still able to drive it to work. Make me nervous that I might not be able to get home tonight. does anyone know what is causing this problem?? I am going to try and get to the dealership later today if they don't close early for New Years eve.
 

·
Registered
Joined
·
15 Posts
when I left work the message was gone so I didn't see any point going to the dealership - hopefully it won't show up again.
 

·
Registered
Joined
·
75 Posts
I just got it as well! I remote started my truck and when I turned the key on the message came on. When I got home I locked and unlocked the truck with the remote and started it up, the message was gone.
 

·
Registered
Joined
·
781 Posts
Has anyone died out on the road or gotten locked out or anything because of this? Mine did it today and it makes me nervous as heck.
 

·
Registered
Joined
·
45 Posts
There is a BCM update, and an inspection of the amount of slack in the harness for the rke. Also, if you have fobs or keys from other vehicles on your key ring, it may be messing with the rke.
 

·
Registered
Joined
·
781 Posts
Well, I wonder if you are supposed to keep the key FOB with the key? I started leaving the FOB at home and when I park, I leave the key in the truck and just use the app from my phone to open the doors. Maybe that triggered the service message?
 

·
Registered
Joined
·
393 Posts
I bought my 2015 Colorado Z71 in January. Almost a week after I bought it the serve theft deterrent system light starting randomly coming on when I started the truck. Sometimes the truck will stay started but other times it just kills the engine. I have to remove the key and open the door to get it to start. Dealership has tried 3 times and it's still acting up. Anybody else having these issues. The first 2 times there were no known issues so they would work with the Colorado plant and after the 3rd time it was "under investigation". Just waiting for possibly a recall. We'll see. It's pretty irritating
Havent had any problems yet, but my 03 malibu had to have the ignition cylinder replaced twice because 1 or more circuits in the cylider burned out, causing the theft system to activate and prevent it from starting. I have noticed the key is hot when I remove it from ignition in my colorado and wondered if it would have same issue.
 

·
Registered
Joined
·
2 Posts
This problem has just happened to me twice on start up in the past week ( code appears, truck dies).
I have a base model, no remote start, no other FOBs on my key ring. I have had my 2015 Colorado almost 1 year now with no other problems.

We are in the middle of quite the cold snap currently ( high minus 30's C with the windchill values). Wondering if this may have something to do with it.
Bought my truck mid Feb last year and it was fairly mild from that point on, so this is first full winter with it.

Anyone else still experiencing this?
 

·
Registered
Joined
·
1,280 Posts
I've had this happen a few times, mentioned it to the dealer when I took it in for other stuff but they could never duplicate it & it does not store any codes (I just wanted it noted that I'm having occasional issues).

Here's the scenario. I use fob to unlock truck & start it with the key, Theft Deterrent msg pops up on DIC. Sometimes it will kill the engine on it's own, other times it stays running. In both cases I turn key off & remove it, unlock doors with fob, open & close doors, restart & everything is fine. It will also happen if I start the truck with the App, open door with FOB, the insert key. I don't feel comfortable driving with it on, as for all I know it could die at any moment.

Over the year & a half I've owned the truck it seems to act up more in colder weather (It's been happening a fair bit the past month or so) & also when I unlock the door & get it and start it relatively fast. The DIC always flashes different things on start-up (Bluetooth connected, Warning Ice on road etc), it's almost like the computer is not fast enough to process the info & throws the Theft Deterrent message.

So far it's been mainly a nuisance, but I had a similar issue with on a 2001 ZR2 that progressively got worse until it would finally prevent the truck from starting at all & that turned into a royal pain in the :censored:. It's a well known issue, just Google "GM passlock problems".

I hope the same problem does not start to affect the 2nd Gen Twins down the road...

@GM Customer Service If I brought this issue up with my Dealer before my warranty expires & they cannot solve the issue, what happens when it becomes a bigger issue after my warranty expires?
 

·
Registered
Joined
·
232 Posts
Yesterday on the way home from the grocery store I got the "service theft deterrent system" light and message. Today while I was out running errands it happened again. This time the truck wouldn't start. After three tries of turning the key it finally started. I'm getting a little nervous now. I live in Maine and we're in the middle of a major blizzard so I can only imagine that the dealership will be closed tomorrow. It probably won't mater much because I don't plan to be on the roads tomorrow. I just hope it doesn't leave me stranded on Tuesday and before I can get to the dealership. I just hope the dealership can fix the problem.
 

·
Registered
Joined
·
92 Posts
Over the past few weeks, I've been getting this message every 2 or 3 times I start the truck. Doesn't seem to affect anything but makes me nervous that I may not be able to start it at some point. Was this issue ever resolved? Thanks.

--Dave
 

·
Registered
Joined
·
7 Posts
Has anyone figured out why this message comes up? It randomly pops up and I have to shut my truck off and start it to make it go away, sometimes I have to do it a couple of time before the message and light will go away. Is it a problem with the key or remote?
 
1 - 20 of 21 Posts
Top