Chevy Colorado & GMC Canyon banner

1 - 20 of 30 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys, I just used the throttle body cleaning instructions that were posted and now I have another issue. Before disconnecting the battery, I rolled my drivers side window down (power windows/locks). After completing the TB clean and putting in new plugs, I buttoned everything back up and the truck starts and runs great (thanks for the pics and the post on that!) but now I cant get my drivers side window to roll up and the power locks do not work. The other 3 windows work fine, radio, etc, its just that the drivers power window doesnt work and neither does the power locks. I came across this one other time, but it was due to a bad battery. After replacing the battery, everything worked fine. Is there something I can do about this? Maybe a reset? Fuses appear to be good as well. PLEASE HELP!
 

·
Registered
Joined
·
9,570 Posts
It'll fix itself. Common problem.
 

·
Registered
Joined
·
29 Posts
Man I have got the same problem. I got in my truck this morning and my drivers side window won't roll down and my door locks will not work. Did you ever find a solution to your problem?
 

·
Registered
Joined
·
538 Posts
It may not fix itself. Mine required a new "driver's side door switch." Then again, mine occurred out of nowhere one cold morning...it wasn't associated with disconnecting the battery.
 

·
Registered
Joined
·
29 Posts
brinsmaid said:
It may not fix itself. Mine required a new "driver's side door switch." Then again, mine occurred out of nowhere one cold morning...it wasn't associated with disconnecting the battery.
I wonder if the cold had something to do with it. We have been having these big temperature swings here in Tennessee and the past couple of days it has been really cold. Well cold for Tennessee. Maybe that had something to do with it?
 

·
Registered
Joined
·
538 Posts
drz117 said:
brinsmaid said:
It may not fix itself. Mine required a new "driver's side door switch." Then again, mine occurred out of nowhere one cold morning...it wasn't associated with disconnecting the battery.
I wonder if the cold had something to do with it. We have been having these big temperature swings here in Tennessee and the past couple of days it has been really cold. Well cold for Tennessee. Maybe that had something to do with it?
It was about 7 degrees here when it happened. By far, the coldest day of the year that I can recall.
 

·
Registered
Joined
·
9,570 Posts
Cold messed with batteries so it doesn't surprise me that this problem crops up more when it's cold.
 

·
Registered
Joined
·
5 Posts
Any solutions yet? I installed my new K&N intake last night and now the driver side window as well as the auto door locks arent working. it was 55 here yesterday so Im pretty sure the cold didnt cause it. If anyone has a fix that would be great (save me a trip to the dealership).
 

·
Registered
Joined
·
38 Posts
I went snowmobiling, came back an hour and a half later and started my truck to warm it up and it died, cranked it again and it started, and thats when all this started. took it to the dealership, said my windowmotor and doorlock + window switch fried...they want 4 hundred to fix it
 

·
Registered
Joined
·
291 Posts
i had the same problems a month ago when i replaced my plugs and cleaned throttle body and put on a new muffler. i just disconnected the battery, checked all the fuses (they were good of course), and let it set for about 10-15min...came back and hooked the battery back up and the window and locks worked fine.
 

·
Registered
Joined
·
1 Posts
Had the same problom tues mine the pos. battery terminal was loose came out to start it and nothing happend went to jump it and moved the terminal and lights came back on and started fine. but drivers window and locks wouldnt work. took it to dealer they said it needed reprogramed they tried it still nothing. then they took out the master switch on drivers door played with it put it back in and it works.
 

·
Registered
Joined
·
8,458 Posts
05 colo said:
Had the same problom tues mine the pos. battery terminal was loose came out to start it and nothing happend went to jump it and moved the terminal and lights came back on and started fine. but drivers window and locks wouldnt work. took it to dealer they said it needed reprogramed they tried it still nothing. then they took out the master switch on drivers door played with it put it back in and it works.
Common problem with these trucks. The electrical systems including the pcm and bcm are extremely sensitive to voltage changes. So a bad battery, loose terminal, etc can cause this to happen.
It's like the bcm goes into a "protect" mode. It can even happen from disconnecting the battery while doing maintenance. There are several methods that members have found that will usually fix this.
1. Disconnect the negative terminal and leave it disconnected overnight.
2. Disconnect the negative terminal and touch it to the positive terminal for about 30 seconds.
3. Wait a few days for the bcm to "reset" itself.
4. Unhook the harness from the driver's door master switch and reconnect.

That doesn't rule out the occasional switch going bad.
BTW: Welcome Aboard.
 

·
Registered
Joined
·
68 Posts
i disconnected the battery for the night and conected it this afternoon and it fixed everything...how often am i gonna have to do this?
 

·
Registered
Joined
·
9,570 Posts
Nymets09 said:
i disconnected the battery for the night and conected it this afternoon and it fixed everything...how often am i gonna have to do this?

Anytime you **** with the electrical system and the BCM goes into self-protection.........
 

·
Registered
Joined
·
9,570 Posts
If you bump or disconnect the battery...........
 
1 - 20 of 30 Posts
Top