Chevy Colorado & GMC Canyon banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
So i get in the truck to day it was like 20 here today drive to the gas station and home from work about half way home i notice the truck has warmed up but it is still cold inside. so I crank up the heater, it is cold not heat at all. the blower works but just blows cold air??WTF.. I have an appointment tomorrow just wondering if anyone else had this, 25k on the truck so i am coverd but still. (heater coil???) I also am having them fix my little annoying blower noise that we all seem to have as well....
 

·
Registered
Joined
·
4,049 Posts
Andersonn said:
My heater control went out last week. The tab in the back that holds the cable in place that pulls on the lever to control the temperture broke.
I had that happen two years ago. The guy who installed my head unit left some wires hanging where they shouldn't have been.
Currently however, my heat only works with the fan on the highest setting. :evil:
This one's definately a problem with the blower motor.
 

·
Registered
Joined
·
434 Posts
Scarecrow said:
Andersonn said:
My heater control went out last week. The tab in the back that holds the cable in place that pulls on the lever to control the temperture broke.
I had that happen two years ago. The guy who installed my head unit left some wires hanging where they shouldn't have been.
Currently however, my heat only works with the fan on the highest setting. :evil:
This one's definately a problem with the blower motor.
Sounds more like your resistor than the blower motor. (scarecrow)
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
Got back.. he said the temp control tab was not hooked up and the guy who installed the radio was the culprit. However they pulled the fan and reported no noise. I was just happy to get the heat fixed for free so I did not fight the fan yet. but that is coming up later before the warranty is up.. so mine was a combination of things express here. they also fixed a break light problem while I was there...
 
1 - 5 of 5 Posts
Top