Chevy Colorado & GMC Canyon banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 14 of 14 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I have made a few changes with my equipment this week and trying to narrow down where the issue occurred. I had my truck in for service as the radio would randomly power off and wouldn't come on until the truck sat powered off for a few hours. I got an iPhone X the other day and it will not connect to USB to stream music at all. The center console USB and the USB located in the armrest dont register a USB device detected. The dealer claimed they did a re-program of the radio. So far I have tried an iPhone X running beta iOS 11.2, iPhone 7 Plus beta iOS 11.2 and iPhone 7 iOS 11.1 with the same results. I was able to get an iPod Touch with iOS 10.0.3 to register, but took multiple attempts. Anyone else having trouble with USB devices being seen an as audio source?

Thanks!
 

·
Vendor
Joined
·
630 Posts
1) try turning the phone off and back on again and try again
2) reset the electronics in the vehicle by pulling the positive terminal off the battery for 5-10 minutes and try again. (effectively turning off the electronics on the truck)
3) try to re-install apple car play onto your phone. Completely remove it, then re-install it.
4) Do you have a different cable you can use? If so try a new cable.
5) Does any friends or family have an iPhone X? See if they can get it to work. (this would isolate your phone as the problem)
6) check the software version installed on the truck and see if it matches the latest version. (there's a way to do this but i forget. Maybe someone else knows how to do it)
7) take it back to dealer, show them its not working, and have them re-flash the software/firmware onto the truck. Even if its the same version, it could have been a bad load or an error occurred which corrupted it.
 

·
Registered
Joined
·
1,900 Posts
So - You're running 11.2?
I have iphone 6 and I see the latest update is 11.1 - of which I need to download. If that's the latest version - I'm not sure any of us can offer any help with the iOS (if that's the problem) that you're running.


I pre-ordered a X on 26th and don't have it yet. I don't understand how or why the pre-orders weren't shipped out before they were available in stores. :frown2: My iphone 6 is a bastard child always shutting itself off and I'm ready to GET RID OF IT!! So, I'm interested in this thread for that reason.


Are you paired via bluetooth and can you stream music via bluetooth?

I'll have to download 11.1 and see what happens with iphone 6.

If you can replicate the problem - I would take it back to the dealer!!
 

·
Registered
Joined
·
1,900 Posts
Wow......OK....

I just got my iPhone X last night. Got it all setup. This morning - got the new phone paired with the truck (took a while) and everything seems to work via bluetooth as it did with iPhone 6.

And then...time to test Carplay. Plugged it into my cable - of which has been perfectly fine with the iPhone 6. Nothing...... wouldn’t even recognize it was plugged in and was still connected via bluetooth. Made multiple attempts.

So - I grabbed the USB / lightning cable that came with the phone. BINGO. Carplay connected immediately.

Removed that cable and plugged in original cable again - Nothing.

Hmmmm..... So, it appears.....there’s something ‘different’ about the lightning cable that came with the iPhone X. I will play around a bit more with the gazillion other lightning cables that I have around the house. Maybe there’s a ‘sensitivity’ issue. But it certainly appears - its not a truck issue. I didn’t play with Carplay at all - I was only concerned that it connected and showing on the screen.
 

·
Registered
Joined
·
628 Posts
Wow......OK....

Hmmmm..... So, it appears.....there’s something ‘different’ about the lightning cable that came with the iPhone X. I will play around a bit more with the gazillion other lightning cables that I have around the house. Maybe there’s a ‘sensitivity’ issue. But it certainly appears - its not a truck issue. I didn’t play with Carplay at all - I was only concerned that it connected and showing on the screen.
Glad to know I'm not the only to find this, although mine was with the iPhone 8. I had a couple of older, but still Apple, lightning connectors that had been in my cars for a while and they were not cooperative. The one from a iPhone 5s and even older iPads and iPods worked fine with Carplay and iPhone 8. I'm presuming there is a minor difference in some of the old Apple lightning cables and it is just enough that they may not work with the new equipment and Carplay.
 
  • Like
Reactions: Janster

·
Registered
Joined
·
1,900 Posts
I’m really confused now......

I have 6 different lightning cables and Carplay would not work at all today including the new cable that came with the phone. Had the truck running sitting in my garage. iOS 11.1.1

It recognizes that its plugged in for charging AND I was running the Audio and flipping between my ipod music and the phone. When it was plugged in - it would say ‘My Media’ and the music would stop when I unplugged it. I could then switch to bluetooth Audio (bluetooth symbol) while unplugged. Just no Carplay at all.....

I have one ‘non-Apple- aftermarket’ lightning cable. It only recognized it for charging but it was still playing bluetooth music.

I whipped out my iPhone 6 again - and got the same results - no Carplay. That’s also running iOS 11.1.1.

I’m half suspecting the new iOS.
Over the years whenever there’s been an iOS updates - small things have gotten better. So - If there is an issue with the iOS, I’m sure Applie is already aware of it. Let’s hope they come up with a solution soon. I don’t use Carplay - but - I bought a truck that’s supposed to have it and I want to make sure it’s working in case I need/want to use it.

The saga continues......
 

·
Registered
Joined
·
628 Posts
I’m really confused now......

I whipped out my iPhone 6 again - and got the same results - no Carplay. That’s also running iOS 11.1.1.

I’m half suspecting the new iOS.
Over the years whenever there’s been an iOS updates - small things have gotten better. So - If there is an issue with the iOS, I’m sure Applie is already aware of it. Let’s hope they come up with a solution soon. I don’t use Carplay - but - I bought a truck that’s supposed to have it and I want to make sure it’s working in case I need/want to use it.

The saga continues......
I confirmed by iPhone 8 is running 1.11.1 and I am not having to issues at all.
 
  • Like
Reactions: Janster

·
Registered
Joined
·
1,900 Posts
I confirmed by iPhone 8 is running 1.11.1 and I am not having to issues at all.
Thanks! Has it been consistently working for you (carplay that is)? Just weird that it loaded up yesterday and not today.

I'll have to play around with it in the next few days.....hopefully its just a temporary technical glitch. I've had those before with this truck. :)
 

·
Registered
Joined
·
628 Posts
Thanks! Has it been consistently working for you (carplay that is)? Just weird that it loaded up yesterday and not today.

I'll have to play around with it in the next few days.....hopefully its just a temporary technical glitch. I've had those before with this truck. :)
While I don't use it all the time, it has been consistent except one of the early version of IOS 11 that it didn't like at all. I always start the truck before I plug the iPhone or iPod in whether it is the wife's Malibu or my Colorado. I don't know if it still holds true, but in the early days of carplay it was pretty much required and it has been a habit every sense then for me.
 
  • Like
Reactions: Janster

·
Registered
Joined
·
1,900 Posts
Update. I updated to the latest version of beta software for iPhone X beta 4 and USB streaming was working perfectly now. Just a heads up
What about Carplay??

So....when you say ‘beta 4’ - what exactly does that mean to the rest of us?

What iOS software update will it be and when will it come out?

Thanks!
I’ve been able to play music from my phone while plugged into USB. BUt Carplay does not load up at all.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top