Chevy Colorado & GMC Canyon banner

1 - 8 of 8 Posts

·
Registered
2017 Chevrolet Colorado Z71 4x4 CCLB Diesel
Joined
·
17 Posts
Discussion Starter #1
Installed Sealight S3s for low beams, and felt like the passenger side seems a little off, but is this typical for LEDs? This is my first time ever using LED headlights, historically I've only used HIDs.

Thanks in advance for your time and patience, and for dealing with my ignorance.


Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
4,020 Posts
Any chance the bulb was inserted at the wrong orientation? I see you have a Colorado but I can't tell if you have projector housings or reflector. In any case, I would compare the orientation of the driver's side bulb to the passenger side and see if the actual LEDs are positioned differently. Not sure what else it could be.
 
  • Like
Reactions: needsmospeed

·
Registered
2017 Chevrolet Colorado Z71 4x4 CCLB Diesel
Joined
·
17 Posts
Discussion Starter #3
Any chance the bulb was inserted at the wrong orientation? I see you have a Colorado but I can't tell if you have projector housings or reflector. In any case, I would compare the orientation of the driver's side bulb to the passenger side and see if the actual LEDs are positioned differently. Not sure what else it could be.
Sounds like a plan, I will try and see if I can rotate 90/180° and check output again. (projectors, FYI)

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
190 Posts
The metal bars ( to which the leds are mounted ) need to be vertical . See my instructions at LED Headlights

Maybe a bit bright to look at directly but easy to check if you shine your lights at a shop front window and look at the reflection of the lights/ silhouette of the bars.
 

·
Registered
2017 Chevrolet Colorado Z71 4x4 CCLB Diesel
Joined
·
17 Posts
Discussion Starter #6 (Edited)
I did rotate the bulb to the correct orientation and it now looks as it should, feel dumb for not realizing this as I was installing it... This passenger side is not fun to work on with my bear paws, lol.

Thanks, all.

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
26 Posts
Did you need to install any resistors or harnesses for your DRLs? Or did you just plug-n-play? Any issues?
 

·
Registered
Joined
·
4,020 Posts
Did you need to install any resistors or harnesses for your DRLs? Or did you just plug-n-play? Any issues?
These are plug and play. I’ve had mine installed since last November and no issues.


Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top