Chevy Colorado & GMC Canyon banner
1 - 5 of 11 Posts

· Registered
12 Posts
Discussion Starter · #1 ·
This might be a stupid question, but how the h%*# do I tell if the shift motor and transfer case are both in the neutral position? I think my shift motor needs replacing, since I'm stuck in 2WD and can't get it to shift into neutral, but I wanted to try manually turning to neutral first. Problem is, I can't for the life of me find any indication on either the motor or the transfer case of where the neutral position is. Here are a couple pics, for reference:

Automotive tire Rim Automotive wheel system Auto part Circle
Automotive tire Gear Bicycle part Finger Bicycle chain

Any help would be greatly appreciated! Thanks!

· Registered
12 Posts
Discussion Starter · #3 ·
Shifting Into N (Neutral)
To shift:
1. Park the vehicle on a level
2. Set the parking brake and press
and hold the brake pedal. See
Parking Brake on page 9-41.
3. Start the vehicle or turn the
ignition to ON/RUN.
4. Shift the transmission to
N (Neutral).
5. Shift the transfer case to 2 View attachment 440637
6. Turn the transfer case knob
clockwise to N (Neutral) until it
stops and hold it there until the
N (Neutral) light starts blinking.
This will take at least
10 seconds. Then slowly release
the dial to the 4 View attachment 440638 position. The
N (Neutral) light will come on
when the transfer case shift to
N (Neutral) is complete.

Page 9-39 in the 2015 GMC Canyon Owners Manual

Thanks for the quick reply! Unfortunately, I already tried this and it didn't work. I also tried running the relearn procedure from SPS and that didn't work either. I wanted to try manually turning the gear to the N position, I just can't find any indicator of the N position on either the motor or the gear in the transfer case.

· Registered
12 Posts
Discussion Starter · #8 ·
Have you ever changed the fluid in the transfer case?
Does it go into 4HI and/or 4LO?
No, I haven't ever changed the fluid. And no it won't go into 4H or 4L - stuck in 2H and giving me "Service 4x4" error. I tried reprogramming the TCCM and running a relearn from SPS, but I'm still getting code "C038D: Range Actuator Position Not Learned".
1 - 5 of 11 Posts