Chevy Colorado & GMC Canyon banner

1 - 14 of 14 Posts

·
Registered
2016 Chevrolet Colorado Z71
Joined
·
7 Posts
Discussion Starter #1
New to the forum. I mainly joined looking for help. I changed my spark plugs earlier this week, and apparently, we did something wrong. Truck runs rough and won't get above 25 mph. At any rate, I have gotten some ideas as to what my problem may be, so I'll start there, and ask if I have any questions. I look forward to sharing knowledge, experiences, and Ideas.
 

·
Premium Member
2017 Chevy Colorado Z71 Extended Cab 4WD Summit White
Joined
·
1,438 Posts
Welcome Aboard.
Sorry to hear that your Spark Plug Change did not go so well. I would recommend looking at all those lines make sure everything is still plugged in and not broken. Even a small vacuum type line. Modern motors don't make much vacuum but they still make some.
 

·
Registered
2016 Chevrolet Colorado Z71
Joined
·
7 Posts
Discussion Starter #3
Thank you! We're gonna tear into it again this afternoon...
 

·
Registered
Joined
·
4,630 Posts
Did you buy OEM plugs or those at the auto-store? What brand and number?

make sure both power packs are plugged in

we need pictures of your truck too...

@CaryBosse just changed his, he knows stuff
 

·
Registered
2016 Chevrolet Colorado Z71
Joined
·
7 Posts
Discussion Starter #5
I originally got Bosch, but I got OEM that we will install today. Ac Delco 41 something, I think. We replaced one at a time.
 

·
Premium Member
2017 Chevy Colorado Z71 Extended Cab 4WD Summit White
Joined
·
1,438 Posts
The DIY nightmare. Hopefully it is something real simple.
 

·
Registered
Joined
·
4,630 Posts
I watched a video and lots of stuff you have to disconnect to get the intake manifold off to get to the sparkplugs
 

·
Registered
2016 Chevrolet Colorado Z71
Joined
·
7 Posts
Discussion Starter #9
I may have found the problem, fellas. These are the brand new Bosch plugs we put in tuesday...
391572
 

·
Registered
2016 Chevrolet Colorado Z71
Joined
·
7 Posts
Discussion Starter #14
It runs better, as far as plugs, but we still get codes for throttle body and mass airflow sensor performance. We put a new maf sensor on it, and it's still not right. Guess I'll take it to the dealership.
 
1 - 14 of 14 Posts
Top