Chevy Colorado & GMC Canyon banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,763 Posts
Discussion Starter #1
Been having some weird issues lately with the truck. Some can be blamed on the cold, but there's definitely something up that's progressively getting worse.

Once the truck warms up, I notice it when I stop or am in a parking lot for example when you are pulling slowly into a spot or leaving it. The RPM's drop WAY down to the point the truck almost stalls out and then they bounce back up to 700 or so, then drop back down to around 500 or slightly below.

Obviously seems much worse when I have the defroster on but only slightly better when everything is off.

I also get major fluctuations in the electrical power when this happens. The headlights get very dim and come back to life when I give her some gas...windows go slower, etc.

I ran a bottle of fuel system cleaner through it, and have gone to several gas stations thinking I'm getting some bad gas....even bit the bullet at Christmas time and treated my truck to some 93 octane gas. No change.

Throttle body looks good...although I haven't changed the fuel filter yet.

My truck is emitting a slight whine lately, one like I've heard when my parent's GMC Jimmy was making when the alternator was going. Granted it's not nearly as bad as that, but it's just slightly there.

I haven't changed the battery yet...it's still the original battery since I bought it in '04. It's still cranking strong so far though...


Any thoughts before I make a service appointment?
 

·
Registered
Joined
·
193 Posts
I have just about the same issues you are describing. The more I think about it the more Im inclined to believe its got to be an electrical issue. I am gonna take a shot at replacing the battery shortly to see if it resolves the issue. Its my best guess. The battery cranks strong, but Ive also noticed that its doesnt hold full charge for any length of time.... Let me know if you bring yours in and what they have to say... Im gonna monitor to see what your results are...
 

·
Registered
Joined
·
1,445 Posts
I would get your alternator checked at an autoshop to see if it's outputting what it should.
 

·
Registered
Joined
·
9,864 Posts
Sparky87 said:
I would get your alternator checked at an autoshop to see if it's outputting what it should.
X2.

Although the lights dimming and the windows rolling slowing does sound typical of when the idle drops really low like that. So really I'd like to know whats causing the low idle problem first. Sounds like maybe a dirty throttle body or perhaps a dirty MAF. Try cleaning those and see what happens. Also I know there is some updated software to reduce idle speed symptoms available from GM so you could pay a visit to the dealer. I think ECM reprograms are covered under 80k mile emissions warranty but you may wanna check first.
 

·
Registered
Joined
·
193 Posts
hmm....has there been any software updates since Sep 07 for the 04s? Thats the last time mine was updated. Also this issue for me has just arrived during the winter time. I have already cleaned the MAF and throttle body, new plugs, and verified alternator is putting out like it should.... All I can figure is a battery, but i dont see how that would affect the idle...
 

·
Registered
Joined
·
9,864 Posts
Not sure on the updated software but if all that checks out ok, it could just be all the extra added loads like the heater. defroster ac, wipers, headlamps and power steering that all rob power from the engine. This sometimes causes the idle to slow down alot and the PCM tries to adjust the throttle blade to open more to compensate for the loads and to rev the engine a little bit higher. This is kinduv a characteristic of the drive-by-wire system.
 
1 - 6 of 6 Posts
Top