Chevy Colorado & GMC Canyon banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 18 of 18 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter · #1 ·
Does anybody in the Forum have the following display in the DIC? The trouble starts when I turn on the truck, the screen was black and after awhile, this message came up. It does not go away even after I stop the truck. The fan keeps on running for about 2 minutes, then the screen goes dark. All this time, I do not have any control of the AC, Navigation etc., I will take it in for a check up on Monday. The truck has 18000 miles on it.
 

Attachments

·
Registered
Joined
·
592 Posts
Wow, weird. Almost looks as if it's waiting for some code, meaning a write phase to the EPROM in the ECU/ECM.
Be interesting to see what it turns out to be...keep us updated!
 

·
Premium Member
Joined
·
4,891 Posts
Yep totally seen that before. This is what happens when it's getting flashed for an update. I remember similar screens from installing the Android Auto update myself, which while technically I was able to fully complete, still wasn't right because it needs a dealer special tool to do a calibration afterwards.





You HAVE to go back to the dealer to get this resolved.

Trust me, no one can fix this for you without a trip to the dealer unless you know someone with all the dealer's equipment that will do it for you.
 

·
Registered
Joined
·
5,897 Posts
Never saw this message, but a while back there was a TSB for an update. Perhaps the system is saying "get it done?"
 
  • Like
Reactions: Toughsox

·
Premium Member
Joined
·
4,891 Posts
Never saw this message, but a while back there was a TSB for an update. Perhaps the system is saying "get it done?"
Nope that will never come up unless a formatted upgrade boot drive was inserted for the truck to be updated. It is a system update boot sequence and now it's looking for the boot USB drive. I'm thinking at some point that was attempted and it never fully loaded the installer before someone tried to quit and the system finally finished processing.

Think of it kinda like when you run windows update and when the computer shuts down it counts up to 30% restarts, finishes installing, counting from 30 to 100%. Well if you ever interrupted that any of that process but just powering off your computer, eventually at some other shutdown or restart it will pick up where it left off and continue.


PS. It never ceases to amaze me that when I can give someone a definitive answer on something you always post some alternate hypothetical possibility???? Why do you always do that? Do you just like
me?


Did the screenshots of me doing the damn install I posted not convince you for some reason?

Why would you suggest some dumb crap like that and continue to drive speculation for the poor guy?
 

·
Premium Member
Joined
·
4,891 Posts
Mine had that same message, had to have a new human machine interface module. Thank goodness under warranty.
On mine when I got the "calibrate device" it was sooooo scared I bricked the HMI. My heart sank and I was dreading having to buy a new one. Fortunately the tech I know is awesome and was able to get it back by finishing the steps I couldn't do without the dealer software.

Since the OP's pic looks like it requesting the media to begin an update. Hopefully the dealer can just input an update USB drive and let it finish off and everything will turn out ok. *fingers crossed*
 

·
Registered
Joined
·
197 Posts
Yep totally seen that before. This is what happens when it's getting flashed for an update. I remember similar screens from installing the Android Auto update myself, which while technically I was able to fully complete, still wasn't right because it needs a dealer special tool to do a calibration afterwards.





You HAVE to go back to the dealer to get this resolved.

Trust me, no one can fix this for you without a trip to the dealer unless you know someone with all the dealer's equipment that will do it for you.


This looks like an absolute answer. Wonder what happened to it? Looks like it lost its memory?
 

·
Premium Member
Joined
·
4,891 Posts
This looks like an absolute answer. Wonder what happened to it? Looks like it lost its memory?
More info than anyone prolly cares about but...

It was my bad for trying to do the update myself without GMs tools.

I found and read through the dealers instructions and thought it all sounded really simple, like a 15-20 minute job and couldn't understand why dealers were making people wait 2-4 hours for the Android Auto update.

So I got my hands on an update drive and tried it myself, hoping I would be able to share it for others that wanted to do it themselves.

Well long story short it's not a fast install and there is that "calibration" that has to happen so other than almost bricking my HMI module I learned that it really cant be done much faster than 2 hours and definitely not do-able without the dealer anyway. lol :frown2:
 

·
Registered
Joined
·
197 Posts
More info than anyone prolly cares about but...

It was my bad for trying to do the update myself without GMs tools.

I found and read through the dealers instructions and thought it all sounded really simple, like a 15-20 minute job and couldn't understand why dealers were making people wait 2-4 hours for the Android Auto update.

So I got my hands on an update drive and tried it myself, hoping I would be able to share it for others that wanted to do it themselves.

Well long story short it's not a fast install and there is that "calibration" that has to happen so other than almost bricking my HMI module I learned that it really cant be done much faster than 2 hours and definitely not do-able without the dealer anyway. lol :frown2:


I more meant I wonder what happened to the OP. If this started after they were messing with it you would think that info would be given.


Appreciate the info though. :smile2:
 

·
Registered
Joined
·
343 Posts
Does anybody in the Forum have the following display in the DIC?

Onstar pushed out an update during the "early morning hours" of the 22nd. Looks like your update glitched. As others have mentioned, it will require a trip to the dealer. Gotta love remote updates that are out of your control.
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #12 ·
Here's my update on the DIC message. Well, I took the truck in this afternoon. They called me back saying that a HMI module has to be replaced and need to keep the truck overnight or even maybe have to wait until Wednesday. They have to get the module from GM. Other than that, the service advisor did not elaborate any more, he's kind of an a-hole with an attitude of only he knows everything. I will try to talk to the mechanic who works on my truck to find out more on what was going on.
 

·
Registered
Joined
·
444 Posts
Onstar pushed out an update during the "early morning hours" of the 22nd. Looks like your update glitched. As others have mentioned, it will require a trip to the dealer. Gotta love remote updates that are out of your control.
Wait, so they actually push out remote updates? I thought updates were only applied at the dealer.
 

·
Premium Member
Joined
·
4,891 Posts
Here's my update on the DIC message. Well, I took the truck in this afternoon. They called me back saying that a HMI module has to be replaced and need to keep the truck overnight or even maybe have to wait until Wednesday. They have to get the module from GM. Other than that, the service advisor did not elaborate any more, he's kind of an a-hole with an attitude of only he knows everything. I will try to talk to the mechanic who works on my truck to find out more on what was going on.
So why are they keeping your truck? It's not like you need this to be safe to drive?

Personally Im not a fan of other people keeping my vehicles because Ive found they just don't treat them the same way you would.

Get your truck back and go back when they have the parts :serious:
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #15 ·
So why are they keeping your truck? It's not like you need this to be safe to drive?

Personally Im not a fan of other people keeping my vehicles because Ive found they just don't treat them the same way you would.

Get your truck back and go back when they have the parts :serious:
They claimed to have the thing dismantled and thinking the HMI module would come in and reinstall the new one to save some work. But I just got a call from the dealer saying that the HMI module is on "National Short Supply" and don't really know when the dealer will get one. So they reassemble my truck and I'll drive it without a good DIC display. Like you say, it is safe to drive but just a little inconvenience for now.
 

·
Super Moderator
Joined
·
4,277 Posts
My 2016 is stuck on the same screen then blacks out. It went out 4 hours away from home on our return trip from San Diego. Just when everyone fell asleep and I needed tunes. ?

Pulling the stereo HMI fuse obviously didn't help. Read up on the issue on the Silverado forums and it's quite common for them. Essentially it's a failed HMI module and it needs to be replaced. If I'm lucky it will just need to have the update installed by the dealer but I'm doubtful. I'll take it I tomorrow to have them diagnose.
 

·
Registered
2016 Chevy Colorado Z-71
Joined
·
25 Posts
Nope that will never come up unless a formatted upgrade boot drive was inserted for the truck to be updated. It is a system update boot sequence and now it's looking for the boot USB drive. I'm thinking at some point that was attempted and it never fully loaded the installer before someone tried to quit and the system finally finished processing.

Think of it kinda like when you run windows update and when the computer shuts down it counts up to 30% restarts, finishes installing, counting from 30 to 100%. Well if you ever interrupted that any of that process but just powering off your computer, eventually at some other shutdown or restart it will pick up where it left off and continue.


PS. It never ceases to amaze me that when I can give someone a definitive answer on something you always post some alternate hypothetical possibility???? Why do you always do that? Do you just like
me?


Did the screenshots of me doing the damn install I posted not convince you for some reason?

Why would you suggest some dumb crap like that and continue to drive speculation for the poor guy?
My 2016 Z-71 is doing it now after disconnecting the ground in my battery to put back on for better connection because my alternator was not always charging my battery, I had jumper cables but guy I work with used a little Viking jump starter box and it came up when I started it! Stays on even when truck is off! Any suggestions/help would be greatly appreciated!
 

·
Registered
Joined
·
1 Posts
Nope that will never come up unless a formatted upgrade boot drive was inserted for the truck to be updated. It is a system update boot sequence and now it's looking for the boot USB drive. I'm thinking at some point that was attempted and it never fully loaded the installer before someone tried to quit and the system finally finished processing.

Think of it kinda like when you run windows update and when the computer shuts down it counts up to 30% restarts, finishes installing, counting from 30 to 100%. Well if you ever interrupted that any of that process but just powering off your computer, eventually at some other shutdown or restart it will pick up where it left off and continue.


PS. It never ceases to amaze me that when I can give someone a definitive answer on something you always post some alternate hypothetical possibility???? Why do you always do that? Do you just like
me?


Did the screenshots of me doing the damn install I posted not convince you for some reason?

Why would you suggest some dumb crap like that and continue to drive speculation for the poor guy?
You said it will never happen yet it did on my truck. We were away on vacation and when I got back, my battery was totally drained. After recharging it and getting the truck started, this screen is what I got. Nothing is plugged in to any port.
 
1 - 18 of 18 Posts
Top