Chevy Colorado & GMC Canyon banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 46 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
20% of the time my phone doesn't get recognized. Siri commands work occassionally (read: not always). The NAV interface stinks and there is no way to disable voice navigation permanently. Voice commands come in about 2x music volume.

Ordered a phone mount and will disable Car Play when it arrives. This way I can use Google Maps/Ways and not have to look at the romper room car play GUI.
 

·
Registered
Joined
·
77 Posts
Well, I like it. Have had/still have some issues learning to use it properly.
Still learning, so maybe I'm wrong about these:
Siri commands are different from MyLink? commands - you have to press and hold the button for Siri. Just a press goes to MyLink.
As for NAV interface, isn't that OnStar?
With Apple maps, when a nav voice comes in, adjust the volume - it's independent of music volume, and is remembered.
What we (I) really need is a good tutorial - GM and CarPlay for dummies:roll:
 

·
Registered
Joined
·
8 Posts
Ive had weird connecting issues too.

Initially, it wouldnt charge... but that was because of all the lint in the lightning port... oops
Now, some of the time, the phone will charge but wont let me use the projection on the colorado display.

Seems to work better when i leave my gf’s house instead of my house. Super weird.

Other than that, the only issue i have, on occassion, is that pandora or amazon music indicates its playing on the main display, but the DIC (speedo display) will show that the radio/xm/usb playing (which is what actually plays at the time...)

Havent done too much troubleshooting otherwise, i have music on a usb drive that seems to work ok. The Apple Maps works fine for me otherwise.

I wonder if connecting to bluetooth or the chevy to my home wifi is messing it up...

Im running a 6S with an Amazon basics lightning cord, fwiw.
My gf just got an iphone 8, i might borrow that for more testing.

Collie is right about the volume, when she gives directions, turn the volume down while she speaks.

What phone mount did you order?
 

·
Registered
Joined
·
1,250 Posts
After I did the iPhone 11.3 (latest version) update car play works great.
 
  • Like
Reactions: greco2003

·
Registered
Joined
·
80 Posts
20% of the time my phone doesn't get recognized. Siri commands work occassionally (read: not always). The NAV interface stinks and there is no way to disable voice navigation permanently. Voice commands come in about 2x music volume.

Ordered a phone mount and will disable Car Play when it arrives. This way I can use Google Maps/Ways and not have to look at the romper room car play GUI.
You stink! Car play is great, no issues here.

Sounds like you have problems with the cable you are using. You can edit the voice settings in Google maps. Sounds like ID 10t error maybe.
 

·
Registered
Joined
·
628 Posts
The latest version of IOS is 11.0.3, which I am sure that is what LBM 17Z71 meant. Once I upgraded to 11.0.3 it has worked liked a charm, prior to that is was a bit goofy at best. Also, if you are on a 5s or below, you may find that Siri slow to respond when connected vs when not connected. My truck has Nav and Bose, so the sound quality is good and the nav meets my needs so I don't use google or apple maps. More than once, I have gotten the mylink voice when I was trying for the Sira prompt and that is irritating, but I'm pretty sure it is me not paying attention to how long I hold the button down.
 
  • Like
Reactions: MaineMan

·
Registered
Joined
·
578 Posts
Carplay works great for me but I'm still on version 10.3.3.
 
  • Like
Reactions: greco2003

·
Registered
Joined
·
65 Posts
I'm still on the 10-version of iOS holding out for the real 11.1 update. But, I've found I pretty much never have issues if I plug my phone in before I turn the key on. I usually use the remote start, so once I'm in, I get everything set up, then turn the key before taking off. If I plug my phone in after the key is on and the truck is running, or especially in gear, its a crap-shoot whether it will work or not.
 

·
Registered
Joined
·
329 Posts
I’ve gotten so frustrated with CarPlay on my iPhone 6 Plus that I have disabled it. I have the latest iOS and that actually made it worse. I found that once I turned it off all of my other apps and Mylink features stabilized right away. No more phone call drops. No more inability to recognize or pair the phone. No more every time I use Waze my music starts playing. No more interference between the Nav system and the phone map app. No more hung Nav screens. It amazing. After 30+ days of hassle free use I turned on CarPlay in the forlorn hope that now everything being stabilized it might behave itself. No such luck. Within 10 minutes things went goofy. Turned it off and everything went back to fine. I’ve given up on CarPlay.
 

·
Registered
Joined
·
285 Posts
I tried CarPlay and Android Auto when renting a car in California last summer. They both suck. Full mirroring is the only thing I'd ever bother with, not some dumbed down filtered UI.

I'll live with the GM interface in my 2015. When I need better navigation w traffic I fire up Google Maps on my phone on a magnetic vent mount.

I only listen to radio for the most part, and actually when plugged in the music interface to the iPhone isn't bad for searching/playing tunes.
 

·
Registered
Joined
·
628 Posts
For those that are interested IOS 11.1 was released today and carplay is working fine, no lags or connection problems.
 
  • Like
Reactions: greco2003

·
Registered
Joined
·
578 Posts
20% of the time my phone doesn't get recognized. Siri commands work occassionally (read: not always). The NAV interface stinks and there is no way to disable voice navigation permanently. Voice commands come in about 2x music volume.

The voice commands volume can be adjusted separately from the music volume. When the voice commands are talking lower the volume at that point. You music will stay as it was.
 

·
Registered
Joined
·
244 Posts
So had something happen a few days ago. Got a text message when I was in android auto and it said do I want to reply. How can I reply? Pushed talk but came up with the normal thing.
 

·
Registered
Joined
·
1,891 Posts
Love the Android Auto. It is fantastic. Uses Google for maps and everything. Texting and googling info is a breeze, all hands free, just fantastic.
 

·
Registered
Joined
·
93 Posts
So it does work after all.
It's been a year and I couldn't figure it out so i finally searched for a video.
 

·
Registered
Joined
·
15 Posts
I too find my IPhone isn't recognized by Car Play 30% of the time I plug it into the truck. Truck is up to date according to the dealer and I am running the latest 11.2.2. What happens when I have issues is that I plug in the phone and the Car Play button turns green. It does not automatically open Car Play like it does 70% of the time. When you press the Car Play button on the screen it does nothing. If you press the audio button than go back to the home screen and press the Car Play button it will open Car Play. This issues happens using either of the two USB ports and with a brand new Apple cord. Very frustrating!


I had a 2018 Silverado thru the weekend while my Colorado was at the dealer waiting on parts. I drove the wheels off the Silverado all weekend and purposely used Car Play. Many key cycles and pugged and unplugged the phone many times. I was using the same Apple cord and my same IPhone 7 and the Silverado Car Play worked flawless!


So what's the deal? Is the 2018 Silverado radio running different software? I feel that my issues are truck/radio software design related and not let's say a bad radio? Which means it is what it is. In any case I plan to take my truck back to the dealer when I can demonstrate my Car Play issue for what its worth. G.B.
 

·
Registered
Joined
·
53 Posts
I too find my IPhone isn't recognized by Car Play 30% of the time I plug it into the truck. Truck is up to date according to the dealer and I am running the latest 11.2.2. What happens when I have issues is that I plug in the phone and the Car Play button turns green. It does not automatically open Car Play like it does 70% of the time. When you press the Car Play button on the screen it does nothing. If you press the audio button than go back to the home screen and press the Car Play button it will open Car Play. This issues happens using either of the two USB ports and with a brand new Apple cord. Very frustrating!

Just wanted to chime in that I have the exact same issue and those are the same steps I have to follow to get it working. iPhone 6 with a 2017 Colorado.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,222 Posts
Just wanted to chime in that I have the exact same issue and those are the same steps I have to follow to get it working. iPhone 6 with a 2017 Colorado.


Sent from my iPhone using Tapatalk
Same, I posted about this work-around on another Car Play thread. I've also had Car Play crash when a call comes in or not be notified of the call if it's in this "Car Play won't open" state. My Apple Watch notifies me of a call coming in, but that's it. Very annoying.

iPhone 7 with latest iOS, BTW.
 

·
Registered
Joined
·
446 Posts
You can edit the voice settings in Google maps. Sounds like ID 10t error maybe.
Since when can you choose the map program in Apple Car Play. I thought it always defaulted to Apple Maps. (Unlike Android Auto where you can choose between Google Maps and Waze).

As far as adjusting the volume I just turn the volume knob (granted this is Android Auto) while the voice is talking to adjust the loudness. Maybe Car Play doesn't allow that? That would seem strange, though.

Oh, and look at it this way, at least GM isn't making Car Play a subscription service ($80/year) like BMW is doing.
 
1 - 20 of 46 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top