Chevy Colorado & GMC Canyon banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 2 of 2 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter · #1 ·
The trailer aux power to the trailer plug has gone out. :crying: I no longer have power at the 7 blade plug. I went into the :cluelesspower distribution centre, but there is no fuse there for the trailer aux power. In the manual it shows a fuse for the trailer aux power. I found two 10 amp fuses that are ok, but it calls it a maxifuse and can not locate it.
Has anyone ever replaced this fuse? can you take a photo to show where it lives or tell me how to find it?
Thanks
:nerd:
 

·
Registered
Joined
·
4,254 Posts
I was unable to locate a reference for a "maxifuse" for the trailer wiring circuit. In the 2011 Service Manual i see reference for a 30amp inline fuse located somewhere between Junction 107 (J107) and Junction 108 (J108 ).

According to the Manual, J107 is located in the engine harness 1.6 inches from the breakout to the knock sensor. J108 is located 1.6 inches from the breakout to the generator X1 connector. The generator X1 connector is the two pin connector. It appears that the fuse would be located somewhere in the harness on the left side of the engine.

I have a 2011, but do not have the towing option and my engine is not a 3.7.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top