Chevy Colorado & GMC Canyon banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
New Colorado, 1 week old, 650 miles. Went to start it up and it was dead. Key turned but nothing. I turned the wheel and shifted from park to drive to park and restarted. It started up but Stabilitrak light, TCS and engine light all came on and truck drove in limp mode. (Oddly transmission clunked when I shifted to drive). Shut it off. Restarted and it ran fine but engine light was still on. Parked it until Monday. Restarted Monday and drove (now in limp mode) to the dealer. Truck is throwing lots of codes which explains limp mode but they can't find anything wrong with it or why all the codes came on. I'm wondering if parking with the wheels turned and head in against the curb explained the ignition problem which somehow tripped all these codes? Does that make any sense?
 

·
Registered
Joined
·
26 Posts
I was getting the same lights. Turns out a Faulty ABS sensor causing all types of errors and intermittent... Came on 2 or three times after I got it but would go out after a few minutes. Truck ran fine but the lights were a concern. No issues for a week or so then intermittent again. Drove an hour on the highway without lights. Then as I was cruising for a while at 70, the lights came on and would not go off. The next morning they were off and didn't come on until it was doing 50mph and shifting from 3 to 4 or 4 to 5. The Dealership told me it's super rare (of course) and an easy fix. hope that fixes all the little gremlins.
 

·
Registered
Joined
·
20 Posts
I had similar issue, ABS, traction control and Stabilitrak went.

For me the terminals that connect to the brake module corroded. GM in all its infinite wisdom took two months to replace the terminals because they shipped it on the slow boat from china. Before doing this, they changed the wheel bearing assembly completely and the break module. The dealer I purchased from and USED to go to were pretty incompetent and lazy so this should be a pretty quick repair.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks for all the input. Service Dept. cleared all the codes and was unable to duplicate the problem. Truck is driving fine and they couldn't find anything wrong. Guess I'm now in fingers crossed mode now, lol. If anything changes, I'll update. Thanks again for the input!
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
4 Participants
ComeOnMan
Chevy Colorado & GMC Canyon
ColoradoFans.com is the best forum for the Chevy Colorado community to discuss the truck’s reliability, diesel or transmissions problems and more.
Full Forum Listing
Top