Chevy Colorado & GMC Canyon banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 24 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Well today was an interesting day... Took the Colorado on its first trail run up in Plumas National Forest here in California. Made it about 6 miles in on dirt terrain (no 4wd necessary) and the truck shuddered and died. Was able to get it restarted and made it about another 1/4 mile before it shut down with the check engine light on. Had Onstar run a diagnostic on it and they said it is throwing 6 trouble codes, all engine/drivetrain related. Truck was recovered from the trail and is being towed to the dealer today to see what's going on, will keep everyone posted!

Quick note that when the truck stopped running I received two messages repeatedly on the DIC, one for "ice possible drive with care" even though it was 75 out and another "trailer brake engaged". No idea what is going on!



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
660 Posts
Quick note that when the truck stopped running I received two messages repeatedly on the DIC, one for "ice possible drive with care" even though it was 75 out
so, I am guessing you didn't see the ice?
but seriously, that really sucks, having your day cut short and having to get towed. After you got it running, how long did you wait before moving the truck again?
 

·
Registered
Joined
·
634 Posts
Let us know what it ends up being. I've been spending a lot of time up there myself and would hate to get stuck in some of the places I've gone to.

Is the snow mostly gone on the forest service roads yet? Three weeks ago there were still some very deep spots...
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
so, I am guessing you didn't see the ice?

but seriously, that really sucks, having your day cut short and having to get towed. After you got it running, how long did you wait before moving the truck again?


Lol yeah no ice visible where we were, way too hot!

When it restarted I let it run for about 2 minutes and let it roll back to a flat area before the incline we were going up. Was running fine so we continued and then it died the second time.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
Let us know what it ends up being. I've been spending a lot of time up there myself and would hate to get stuck in some of the places I've gone to.

Is the snow mostly gone on the forest service roads yet? Three weeks ago there were still some very deep spots...


Pretty much! Passed a little snow on the way up to Eureka Ridge but it's pretty much gone now.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
660 Posts
Lol yeah no ice visible where we were, way too hot!

When it restarted I let it run for about 2 minutes and let it roll back to a flat area before the incline we were going up. Was running fine so we continued and then it died the second time.


Sent from my iPhone using Tapatalk
that sucks. I guess you won't know anything till tomorrow? Did instar know it threw a ice condition code AND it was 75? lol I would like to hear their reaction.
 

·
Registered
Joined
·
19 Posts
6 trouble codes? I'll hazard a guess and say a bad common ground or possibly damaged/loose harness connector.
 
  • Like
Reactions: Vinolush

·
Premium Member
Joined
·
8,868 Posts
I remember another circumstance almost identical to yours but can't remember the thread.

The external temperature thing being wonky is what caused the ice message. As a result, the vehicle had to shut down in some type of protection mode.

The person or persons that have had this happen to them will hopefully read this to share their insight.
 

·
Registered
Joined
·
634 Posts
Pretty much! Passed a little snow on the way up to Eureka Ridge but it's pretty much gone now.


Sent from my iPhone using Tapatalk
Any good fishing spots near that road?

We did Grouse Ridge road to the end a few weeks ago and found some great lakes within an easy hike but no fish....
 

·
Registered
Joined
·
1,921 Posts
Any updates.
As already stated, lost communication with ECM or battery cable poor connection maybe..can only guess at this point. Was the battery able to turn the engine over, or just no response at all when trying to crank?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #16 ·
Hello all! Dealer inspected the truck this morning, they called me asking what was wrong because when they went out to sign it in it started right up and no check engine light!!

I told them what happened and they were able to pull the codes but we're having a hard time identifying a specific issue. They ended up clearing the codes and then hooked a laptop up and drove it around, they were able to replicate the issue and it stalled again a few miles into their drive.

Got a call this afternoon and it appears that they have identified the problem, a faulty crank position sensor. A new one has been ordered from Michigan and they anticipate having the repair completed by Friday.

Overall very happy with the experience thus far, GM covered a rental for me and the techs seem really excited to be working on a diesel, service advisor said it is the first one they've been able to work on!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,921 Posts
Awesome, thanks for update. At least it is easy to change. I hope it is just the sensor and not related wiring/plug/pin creating a headache.
 

·
Registered
Joined
·
2,088 Posts
Good to know it's just a common modern vehicle issue instead of something diesel specific.
 
  • Like
Reactions: Brayan Rosales

·
Registered
Joined
·
1,002 Posts
Good to know it's just a common modern vehicle issue instead of something diesel specific.

So far, for a baby engine, and I mean first year release, There are not a lot of issues that plague baby models. I hope this is the trend as we put miles on them.
 

·
Registered
Joined
·
67 Posts
The thing that bothers me though is that it threw 6 codes for this one fault, and then the ice warning on the DIC along with the trailer brake engaged.

Do you have a list of what these codes are? Would like to keep a list for myself so I know what to look for.
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top