Chevy Colorado & GMC Canyon banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I bought a 2005 Colorado 3.5L. On Occasion the truck will not start (will not turn over). All the gauges go from working to not working while in this condition, low fuel, ABS, Security light. When/If I get it started additional symptoms are the A/C doesn't work, door locks do not lock/unlock when going in/out of gear, ...etc. I am thinking my CPU is going bad. Any ideas?
 

·
Registered
Joined
·
4,254 Posts
:welcome to C'Fans

What do you do to get it started? Just keep trying, jump start it, or what? Have you done anything to troubleshoot this issue? It is counter-productive to make suggestions only to have you say "already tried that".

First thing to do is insure that the battery is in good condition and cables are clean and tight. If you haven't already done so, have the battery load tested. Most Advance Auto or AutoZone stores will do it free of charge.

What is the CPU? Are you referring to the PCM (Powertrain Control Module) or the BCM (Body Control Module)?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
:welcome to C'Fans

What do you do to get it started? Just keep trying, jump start it, or what? Have you done anything to troubleshoot this issue? It is counter-productive to make suggestions only to have you say "already tried that".

First thing to do is insure that the battery is in good condition and cables are clean and tight. If you haven't already done so, have the battery load tested. Most Advance Auto or AutoZone stores will do it free of charge.

What is the CPU? Are you referring to the PCM (Powertrain Control Module) or the BCM (Body Control Module)?
To get it started I scream and yell and keep trying :D

PCM is what I was guessing. Battery is new and wires are tight. Honestly don't really know where to begin since it is random. Also another tidbit is that when it is having the issues my Scanner cannot connect to read codes. Once it returns to normal I can read codes again (not that any are present)
 

·
Registered
Joined
·
4,254 Posts
Do you have any aftermarket electronics installed i.e. head unit, amp, remote start, security system, CB?

Just for something to try: Locate the RUN/CRNK relay in the underhood fuse box. If you aren't familiar with it, there is a decal on the inside of the lid. Find another like relay, maybe the WIPER 2 relay, and swap them. See if anything improves. The RUN/CRANK relay is in the start circuit and many other circuits are powered through it.

There could be a problem in the ignition switch also. Try a different key, if you have a spare.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Do you have any aftermarket electronics installed i.e. head unit, amp, remote start, security system, CB?

Just for something to try: Locate the RUN/CRNK relay in the underhood fuse box. If you aren't familiar with it, there is a decal on the inside of the lid. Find another like relay, maybe the WIPER 2 relay, and swap them. See if anything improves. The RUN/CRANK relay is in the start circuit and many other circuits are powered through it.

There could be a problem in the ignition switch also. Try a different key, if you have a spare.

The radio is not factory (was in it before I got it). So swapped out the fuses. Did the same thing after a short drive. I am going to try and get a video of it when it happens again. Have tried both keys.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top